Provide all Ruby Enterprise dependencies

I was trying to install Ruby Enterprise on my Ubuntu machine. I discover you need to be sure to have some package installed if you really want to build all gems needed by Ruby On Rails.
So be sure to install at least the headers for mysql and sqlite before installing Ruby Enterprise.

$ sudo apt-get install libmysqlclient-dev
$ sudo apt-get install libsqlite3-dev

Afterward you can compile the related gems with the following commands.

$ sudo /opt/ruby-enterprise-1.8.7-2010.02/bin/gem install mysql
$ sudo /opt/ruby-enterprise-1.8.7-2010.02/bin/gem install sqlite3-ruby

Worth reading

http://amitava1.blogspot.com/2010/08/ruby-on-rails-on-centos-55-with.html
http://ubuntuforums.org/showthread.php?t=637973
http://theplana.wordpress.com/2007/05/11/install-sqlite3-on-ubuntu/

Rails ans SQLite3 on Ubuntu

To configure a Rails application in order to use SQLite3 please follow the following steps:

sudo apt-get install  sqlite3 swig libsqlite3-ruby libsqlite3-dev
 sudo gem install sqlite3-ruby

Then create a Rails application as usual and update the environment.rb file in the following way

Rails::Initializer.run do |config|
...
config.gem 'sqlite3-ruby', :lib => "sqlite3"
...
end